Hola Amig@s,

Hoy les traigo una nueva reparaci√≥n. Se trata de un Amiga 2000 que no arranca. Inicialmente funcionaba seg√ļn su propietario pero tras colocarle un adaptador, dejo de funcionar. As√≠ mismo consta de una Blizzard 2060, muy utilizada en la √©poca para acelerar el A2000. Una aceleradora que consta de un 68060 con 128Mb de ram... Nada mal eh? :)

Estado inicial

Al igual que el resto de máquinas que constan de RTC (real time clock) o lo que es lo mismo, máquinas que almacenan y guardan la información del reloj en tiempo real. La teoría está muy bien, pero los circuitos RTC de la época constan de un componente vital para su funcionamiento, una batería 3V recargable.

Advertisement

¬ŅQue sucede con el paso de los a√Īos? Ya hemos visto algunas otras reparaciones en mi blog, de Amigas 500 o incluso 4000 da√Īadas por bater√≠a, donde la bater√≠a se revienta, se crea sulftato y el sulfato se come las pistas y vias del PCB como si fuese mantequilla :)

Advertisement

Ahora bien, como observaremos en las siguientes imágenes, la pila de este A2000 ya presentaba signos de sulfato. Cabe decir, que ya le habían cambiando la pila, pero se habían olvidado de quitar el sultafo que existía en el zócalo de la CPU! por lo que a veces el sulfato en alguno de los pines del zócalo de la CPU generaba un falso contacto y hacía que el A2000 no arrancara (entre otras cosas).

Advertisement

Advertisement

Advertisement

Reparación paso a paso

Lo primero que he hecho es quitar la dichosa batería de tambor y utilizar mi adaptador CR2032.

Advertisement

Este adaptador permite colocar una bater√≠a CR2032 y suplir la funci√≥n de la bater√≠a original del A2000 ‚Äúoriginal‚ÄĚ.

Advertisement

Lo siguiente fue lavar con IPA la zona de la batería para eliminar cualquier residuo, ojo el IPA no quita el sulfato, el limón lo hace :).

Advertisement

Por √ļltimo pero no por eso menos importante, quit√© el z√≥calo de la CPU ya que el sulfato entre los pines jam√°s lo iba a poder quitar del todo.

Advertisement

Coloqu√© el nuevo z√≥calo y por √ļltimo coloqu√© el adaptador de la bater√≠a.

Advertisement

Advertisement

Ahora bien, tras colocar los nuevos componentes, el A2000 hac√≠a algo distinto, mostraba video pero no terminaba de arrancar, ni siquiera mostraba ning√ļn mensaje o color de error. Lo siguiente fue revisar el oscilador. Al visualizar la zona del oscilador, vi que ya lo hab√≠an cambiado con anterioridad pero no solo lo hab√≠an reemplazado sino que en el proceso, se hab√≠an llevado a cuestas b√°sicamente el pin m√°s importante, el de la salida del oscilador que va hac√≠a el ‚ÄúAgnus‚ÄĚ, hablamos del pin 8 (es un Oscilador Dil14).

Advertisement

En la imagen anterior pueden ver el aspecto de la zona del z√≥calo del oscilador tras quitarlo. Pueden observar el pin que le falta. El problema es que se hab√≠an llevado la v√≠a y hab√≠an soldado el ‚Äúpelo‚ÄĚ que era la v√≠a, directamente a la pata del oscilador. Esto puede funcionar pero es muy inestable ya que a la primera que haga contacto con alguna zona, el Amiga deja de funcionar, se resetea, etc.

Tras sanear la zona, coloqué un nuevo oscilador, aseguré el mismo con el resto de patas bien soldadas y tiré un hilo AWG desde la cuenta de ferrita a la pata 8 del oscilador.

Advertisement

Coloco mi super TERMINATOR para que la kickstart arranque m√°s r√°pido y...

Advertisement

Resultado final

Un #ITSALIVE!!!!!!!

Advertisement

Ahora bien, lo siguiente era ver porqué motivo la aceleradora de Blizzard no funcionaba. Recordemos que la 2060 va colocada en el Amiga 2000 en un zócalo especial tipo zorro que tiene para tal fin. Se llama zócalo del coprocesador o CO-PROCESSOR SLOT (CN600 para los amigos) y permite colocar aceleradoras que reemplazan a la CPU onboard en formato DIP (el 68000).

Lo primero que hice fue comprobar los transceptores que est√°n al lado del z√≥calo. Me encontr√© con que tres de ellos estaban fritos.. literalmente no respond√≠an a ninguna se√Īal, as√≠ que lo primero fue quitar no solo los dos 74LS245 sino tambi√©n los 74ALS245 y colocar z√≥calos para facilitar su sustituci√≥n en un futuro. Recordemos que este A2000 seg√ļn el propietario funcionaba, no fue hasta colocar un adaptador cuando dej√≥ de funcionar.

Advertisement

Advertisement

Advertisement

Tras colocar los zócalos y los nuevos componentes, coloqué nuevamente la 2060 pero ésta seguía sin funcionar.

Este es el aspecto de una Aceleradora Blizzard 2060

Advertisement

Tras realizar una inspecci√≥n visual, no ve√≠a da√Īo aparente, salvo una chapuzilla que hab√≠an hecho en el fusible de entrada de tensi√≥n. En vez de utilizar un fusible SMD hab√≠an colocado uno est√°ndar tubular, pero el fusible no estaba cortado. As√≠ que el fallo era otro.

Tras revisar la zona del slot con el microscopio pude ver que hab√≠a algunas grietas en los arrays de resistencias de 47 ohm. Estos arrays parecen pullups aunque la zona en la que est√°n colocadas es muy propensa a recibir alg√ļn golpe, (est√°n justo por encima del slot).

Advertisement

As√≠ que lo que hice fue resoldar todos los arrays, aplicando flux y esta√Īo.

Advertisement

Tras resoldar los arrays, coloqué nuevamente la 2060 en el A2000 y voila! :))))

Advertisement

Finalmente el A2000 quedó con el kit de CR2032 instalado, los tranceptores nuevos y la 2060 operativa :).

Espero que les haya resultado √ļtil.

Salu2.